RECENT POSTS

P5-devel-required

May 26, 2018

Automatic update of required modules documentation

The DevelRequired module only serves a purpose in the development environment of an author of a CPAN module or more precisely a user of the ExtUtilsMakeMaker module. It makes sure that any changes to the required modules specified in the Makefile.PL are automatically reflected in the appropriate text file and in the appropriate source files either explicitly or implicitly specified.

It takes the information given with the PREREQ_PM parameter and by default writes this to the README file, as well as to the POD of the file specified with the VERSION_FROM parameter. Both these defaults can be overridden with the “text” and “pod” parameters in the use DevelRequired specification.

WWW http//search.cpan.org/dist/Devel-Required/