RECENT POSTS

Lua-posix

May 26, 2018

Lua bindings for POSIX APIs

This is a POSIX binding for LuaJIT, Lua 5.1, 5.2 and 5.3; like most libraries it simply binds to C APIs on the underlying system, so it won’t work on non-POSIX systems. However, it does try to detect the level of POSIX conformance of the underlying system and bind only available APIs.

For a while, luaposix contained support for curses functionality too, but now it has its own lcurses repository again, where it is being maintained separately.

WWW https//github.com/luaposix/luaposix